Back to overview
SMTP Connections
Feb 07 at 12:00am GMT
Affected services
Shared Mail Servers
Resolved
Feb 07 at 12:00am GMT
We are looking into reports of connectivity issues with mta.extendcp.co.uk for sending email through the SMTP server. We apologise for any inconvenience caused whilst we continue to investigate.
Update - this has now been resolved but we continue to monitor.
Affected services
Shared Mail Servers