Back to overview
Degraded
Email Connectivity
Apr 27, 2026 at 10:33am UTC
Affected services
Shared Mail Servers
Resolved
Apr 27, 2026 at 12:08pm UTC
Update - The issue has now been resolved, and everything should be back to normal. We will continue to monitor things from our side.
The incident was caused by a sudden spike in traffic to the server, which triggered our DDoS protection and traffic filtering systems.
Affected services
Created
Apr 27, 2026 at 10:33am UTC
We are aware of some intermittent connecticity to imap.extendcp.co.uk. Our platform team are working on this as a priority.
Affected services