Back to overview
Degraded

Issues reported logging into mail

Jun 28, 2026 at 8:00am UTC
Affected services
Shared Mail Servers

Created
Jun 28, 2026 at 8:00am UTC

We've had reports of some customers not being able to login to their mailboxes. Our team are aware and investigating urgently.

Update 11:00 - we've identified the root cause, and a fix has been applied, we will continue working to ensure stability and will update again once fully resolved.